Reporting Features In
Flare and Analyzer




Who Am |?

¢ Nell Perlin — Hyper/Word Services.

— Internationally recognized content creation and
delivery consultant.

— Help clients create effective, efficient, flexible content
In anything from print to mobile.

— Certified — Flare, Mimic, other tools.

— Many years experience trying to keep track of what’s
going on In my projects.



The Issue

¢ How do we track what’s
going on in our projects?
¢ The answer(s):
— Core reporting — Project Analysis
— More detail — File List

— Still more detail — the Report feature

— Still more customizable detail — File Tags and the
Report feature

— And “active” detail — Analyzer




Project Analysis

¢ Select View > Project Analysis.

¢ Displays what MadCap -
considers to be “core” 7] Status Bar
Information.
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Broken Bookmarks

Broken Links r
Database Errors

Files With Changes

Files With Annotations

Topics Mot In Index
Topics Mot In Selected TOC i




Project Analysis

¢ Select a report to open it in the Project Analysis
pane — the editing pane in v.10+, the left pane
pre-v.10.

.-E Project Analysis

@ Project Analysis  * Start Page x
’Erﬂ-ken Links
o @ - ‘_E‘!’ __E View All | [BH] 5= (=] ) F‘age: 1 = of1
This window displays files in your project where a broken link is located. You can double-click a row to open the file.
i

File Folder Link Type Link Text Link Tag Extension




Project Analysis

¢ You can also select another report directly from
the Project Analysis pane.

= Project Analysis
/@ Project Analysis = 1 Start Page x

‘Eraken Links

Broken Boockmarks
Database Errors
Files With Changes
Files With Annotations
Topics Mot InIndex
Topics Mot In Selected TOC
“FIlE Folder

Iype Cink Text Lk Tag Edfension

ws_ftp_features. htm Content/Llintro/

¢ Plus:
— Export to CSV (comma-separated value) form.

— Print the info.
— View different pages in a multi-page report.



Project Analysis

¢ Double-clicking a row opens the topic or
element in question where you can make your

changes.

¢ For example, double- | e - i e
clicking the broken |
link Opens the topic ws. TP Featurs
and h I g h I Ig hts the I I n k. The basic features of WS_FTP allow you fo:

= Connect your PC to a remote FTP site

= Browse files and folders on both the FTP site ar
= Copy and move files between your PC and an |
= Save and organize connection parameters fory
= Resume interrupted file transfers

= Automatically retry failed transfers

= [FEEERTE to another file on the other system
» Track and save the folder paths you visit for guic




Project Analysis

¢ Demo...



File List

¢ Select View > File List — opens in the Editing
pane in v.10+, the left pane pre-v.10.

I_E'] File List = \"'1', ws_ftp_featureshtm % \"{ Project Analysis ‘fi— Start Page x N

5 | & & @ Filter *htm:*.html -

Mame & Path Size Date Modified User Status Title Class 5

account_definition.htm Content\Ddefsh, 3/22/2013 5:25:56 PM Account (definiton)
.&3 M | zppending_files.htm Content\dtransfers', 246 KB [3/22/2013 5:25:58 PM Appending files fil
.&j [ ]| automatic_reconnect.htm | Content\2getstartedt, 129 KB [3/22/2013 5:25:57 PM Automatic Reconnect fil
.&3 []|can_connect_only_to_ip_... | Content\troublel, 961 b... [3/22/2013 5:26:06 PM Can connect only to IP Address fil
_ej []| cannot_connect_to_an_ft... | Content\trouble!, 123 KB [3/22/2013 5:26:06 PM Cannot connect to an FTP site fil
.&j []] Certificate.htm Content\security’, 627 b, [3/22/2013 5:26:01 PM Certificate fil
.&j [ ]| Certificate_Signing_Requ... | Content\security’, 731 b... [3/22/2013 5:26:01 PM Certificate Signing Request fil
a | [ changing_the_current_drive.htm Ftﬂnavigation"\ 1.76 KB |3/22/2013 5:25:58 PM Changing the current drive fil
.&3 [ ]| changing_the_current_fo... | Content'3navigation’, 252 KB [3/22/2013 5:25:58 PM Changing the current folder fil
.&j [ ]| changing_the_host_nam... | Content\2getstarted!, 238 KB [3/22/2013 5:25:57 PM Changing the host name or address fil
_eﬁ [ ]| changing_the_host_type.... | Content\2getstarted!, 265KB [3/22/2013 5:25:57 PM Changing the host type fil
_ej []| changing_the_name_of ... | Content\2getstarted, 179 KB [3/22/2013 5:25:57 PM Changing the name of a site confi..,
.&j [ ]| changing_the_permissio... | Content\Sfilesandfolders, |9.58 KB |3/22/2013 5:25:59 PM Changing the permissions for UNL., fil
.&j [ ] Client_Certificate Verific... | Content\security’, 46 KB [3/22/2013 5:26:01 PM Client Certificate Verification fil
a [ ]| compression_modehtm | Content\Odefs\, 394 b.. |3/22/2013 5:25:56 PM Compression Mode fil
.&3 [ ]| configuring_a_new_ftp_si... | Content\2getstarted’, 148 KB |3/22/2013 5:25:57 PM Configuring a new FTP site fil
.&j [ ]| configuring_active_edit.h... | Content\2getstartedt, 208 KB [3/22/2013 5:25:57 PM Configuring Active Edit fil
_eﬁ [ ]| Connect_using_the_Sites... | Content\2getstarted’, 115KB [3/22/2013 5:25:57 PM Connect using the Sites Menu fil
USR] o | R T A S P PR PRSP U} 1 49 rn | 7077 N Y CLAELET Mk PR - TR F



File List

¢ YOu can:
— Control which columns display.
— Export the info to CSV form.
— Change the order of the columns.
— Change the sort order within columns.
— Control which file types are listed.

[en

All Files (*.%)
Topic Files (*.htm; . html}

MasterPage Files (*.flmsp)

n Page Layout Files (*flpgl)
Snippet Files (*.flsnp)

ct.ht Stylesheet Files (*.css)

‘o_ip Irage Files (*.png;* . brmp;* jpg;* . jpeg;™.bf; tiff, . gif, " swd;* emf,* wmf;* xaml;* xps* exps ™ hd p " wdp * svg;* . ps; " eps; ™. dib)
Multimedia Files (*.asf*wm:™wma ™ wrmv ™ ase wax™wae S ™ midy ™ midi " mpeg:™ mpg:™ . mpa ™ mpe®wav™.au*.mp3;

2 GIF Files (*.qgif)

JPEG Files (*.jpeg;™.jpag)

Re IPNG Files (*.png)

4" Flash Movie Files (*.swf)




File List

¢ Demo...



Report Feature

¢ Select File > New > Add File > Reports.

¢ Report Editor lets you define 124 report types or
combine multiple types into one.

= Conditions Report
Conditions Report  x ’ account_definitionhtm x . File List x ¥ 5 ws_ftp_features.htm x 5 Project Analysis X \ Start Page X §
Report Editor
General Title:
Styles Tables: 2 Bookmarks [ select al | -
Archive [ Broken Bookmarks [ Unused Bookmarks [ used Bookmarks
5 Concepts [] sSelect al |
[ concept Links [ Files with Concepts [ Topics with Concept Links
[ Topics With Concept Links Missing a Concept [ | Topics Without Concepts [ used Concepts
[ used search Filters
= Condition Tags [7] selectal |
Applied Conditions Files With Condition Tags [ Topics with Snippet Conditions
Undefined Condition Tags Unused Condition Tags Used Condition Tags
= Content Files [] select al | i
[ selectall
[ skip empty reparts
|:| Print report after generation
Repart: Add To Archive... l l Open in Browser ] [ Generate




Report Feature

¢ For example, all files with condition tags.

[ used Search Filters

= Conditions Report* b
| [E] Conditions Report* = | account definition.htm  x ¥ =] Filelist x ¥ = wsftp featureshtm x % |1 Project Analysis > % 0 Start Page x
Report Editor
T
General Title:
Styles Tables: ®  Bookmarks [] selectal 1«
Archive [ Broken Bookmarks [ Unused Bookmarks [ used Bookmarks iE |
= Concepts [T select all |_
[ concept Links [ Files with Concepts [ Topics With Concept Links
[ Topics With Concept Links Missing a Concept [ | Topics Without Concepts [ used Concepts

[] skip empty reports
|:| Print report after generation

= Condition Tags [7] selectal

[ Applied Conditions Files With Condition Tags [ Topics With Snippet Conditions

[ undefined Condition Tags [ Unused Condition Tags [ used Condition Tags

= Content Files [ select all |-
[ select al

Report: Add To Archive... l l Open in Browser l [

Generate

Project: C:\Flare Training\ws_ftp\ws_ftp.flprj
Generated: 1/23/2015 11:33:20 AM
By: Owner

Files With Condition Tags

Count: 5
File: Content/1intro/new_features_in_WS_FTP_Professional htm

Condition Taq: Primary_Pro

m




Report Feature

¢ Here’s the full report.

. = = | B [

= “:’=¢:>:l‘ 27 C:\Users\Owner\AppData\Local\T © ~ & ‘ (2 C:\Users\Owner\AppData\L... A
LS S
x @l?egure Search o lﬁ!—| -
~

Project: C:\Flare Training'ws_ftpws_ftp flprj
Generated: 1/23/2015 11:33:20 AM
By: Owner

Files With Condition Tags

Count: 5
File: Content/1intro/new_features_in_WS_FTP_Professional htm
Condition Tag: Primary.Pro
Tag: html

File: Content/dtransfers/appending_files htm
Condition Tag: Primary HOLD
Tag: html

File: Content/4transfers/multipart_transfers.htm
Condition Tag: Primary HOLD
Tag: html

File: Content/security/SSH/Importing_an_SSH_Key htm
Condition Tag: Primary HOLD
Tag: html

File: Content/security/SSL_vs._SSH.htm
Condition Tag: Primary.Pro
Tag: p
Tag: a




Report Feature

¢ Can also use Styles options to format a report.

¢ For example, and with apologies, these settings
on the Styles tab:

= Conditions Report*
[E] Conditions Repart® = | account definition.htm x4 FileList = % = ws fip featureshtm * % [ Project Analysis  x
Report Editor
General
Styles Show Preview
Styles 4 Reportentry @ Property Groups
Archive ReportiGroup ! Alphabetical List
+- ReportHeading
+ - ReportPrefix Properties
- ReportSection
+- ReportText Basic
B Font
FontFamiby '‘Comic Sans M5’
FontSize 12pt
FontWeight bald
FontStyle normal
Calor [ I
BackgroundColor #hbeeff
Borders
Padding=
Margins




Report Feature

¢ Produce this:

-

T,

= | {-:_::)) a C:\Users\Owner\AppData\Local\T © ~ &

x @| Secure Search

@ ChUsers\OwnerAppDataiLo

B G mchiee O

Project: C:\Flare Trainingws_ftplws_ftp.flprj
Generated: 1/23/2015 11:42:22 AN
By: Owner

Files With Cenditien Tags

Count: 5

File: Content/1intro/new_features_in_\WS _FTP_Professional htm

Condition Tag: Primary.Pro
Tag: html

File: Content/dtransfers/appending_files. htm
Condition Tag: Primary. HOLD
Tag: html

File: Content/4transfers/multipart_transfers.htm
Condition Tag: Primary. HOLD
Tag: html

File: Content/security/SSH/lmporting_an_S5H_Key htm
Condition Tag: Primary. HOLD
Tag: html

File: Content/security/SSL_vs. 55H.htm
Condition Tag: Primary.Pro
Tag: p
Tag: a



Report Feature

¢ Demo...



File Tags and the Report Feature

¢ Problem — the Report feature’s categories are
pre-defined.

# Can you create your own custom reports?

¢ Yes, using file tags — “markers” that you create
and apply to topics and other types of files.

¢ You can then generate a report that lists all files
containing a particular set of tags.



File Tags and the Report Feature

¢ To create file tags.

— Select File > New > File Tag Set (or open a File Tag
Set in the Advanced folder on the Project Organizer).

— Use one of the preset templates (MyAuthors... or

MyStatus...) or select MyFileTagSet to define your
own template.



File Tags and the Report Feature

¢ Add or modify the tags as necessary.
— Here’s a file tag set called Color with three tags.

g
— Color
'. Start Page Color =
FileTagSet Editor | | ;4 2 #~ Tag_; Type: Colors
Tag Mame 4 Comment

Blue

Green
Cmres .




File Tags and the Report Feature

¢ To apply file tags:

— Open the Properties pane for a topic or file, select the
File Tags tab, select the tag type, and select the
desired tag — as shown in the next screen.



File Tags and the Report Feature

F" — - — '1
Properties m

e B o e
-~ 1
General Tag Type
File Tags ~ Comment

Taopic Properties Colaors b

[ ] Blue
File Tags Green O

File Tag Sets -

Snippet Conditions

Language

\

Edit Set Unselect Al | Select Al ]




File Tags and the Report Feature

¢ And when you run the report, by selecting File
Tags > File With Tag: Colors, you get this (if
you had applied just the Blue tag to one file):

Project: C:\Templenovo\Karry 3\Karry3 flprj
Generated: 2/14/2015 11:45:21 AM

By: Owner

Files With Tags: Colors

Colors: Color Blue
Count: 1
File: Content/Topic.htm

Colors: Color.GGreen
(Mo files)

Colors: Color.Red
(Mo files)



File Tags and the Report Feature

¢ Demo...



Analyzer

¢ An add-on to Flare.

¢ Reports are similar to those from Flare’s Report
feature but...

¢ Flare’s reports are static — they list changes or
properties but leave implementation up to you.

¢ Analyzer’s reports are active — they list changes
or properties and can help you implement them
or implement them for you.



Analyzer

¢ For example, the Index Keyword Suggestions
report.

This window pane displays a list of files containing text that matches existing index keywords in your project. You can quickly add those index
keywords to the relevant files. Select the rows where you want to add keywords, and click the "Apply" button. Alternatively, you can cpen each
topic and add the index keywaords manually,

Title

File

Keyward

feature_compar... Content/

feature_compar... Content/

W5_FTP Find starting_the_fin... | Starting the Find Utility Content/ E
FTP site dig_browser_dao... | Download Dialog Content/Dcontext/

FTP site dig_open.htm Open (dialog box) Content/Ocontext,

transfer mode dig_ocpen.htm Open (dialog box) Content/Dcontext/

mode dlg_ocpen.htm Open (dialog box) Content/Ocontext,

connect host_name.htm | Host Mame or IP Address (defintion) | Content/0defs/

FTP =ite host_name.htm | Host Mame or IP Address (defintion) | Content/0defs/

IP address host_name.htrm | Host Mame or IP Address (defintion) | Content/0defs/

connect workspaces.htm | workspaces Content/Odefs/



Analyzer

¢ Or the Variable Suggestions report, which scans
for content that matches existing variables.

Alll

Start Page x

F"’f Variable Sugges.tl-::uns x { o Index Keyword Suggestions % {ﬁj_ Statistics \
- 'ﬁ View All | [B] |55 |59 [H] | Page: ufl

__'-_.: L "E |
This window displays content that matches existing variables in your project. You can quickly convert these occurrences to variables. Select the

< o rows you want to convert, and click the "Apply" button.

Context File

»

Suggesticn Type Folder




Analyzer

¢ Or the Markup Suggestions report, which looks
for inefficient code and suggests fixes.

I"} Markup Su ggestions ® j ! Vanable Suggestions X 1"\. o Index Keyword Suggestions X ‘i\_ﬂ._ Statistics X 'x_\‘
e ==~  Apply.. Search Properties... ’ﬁ View all | [H] [& [=] Page:

411l

»

excessive spaces). You can click the "Apply” button to automatically apply the suggestions to the selected files, You can click the "Search
Properties” butten to customize which types of issues to display in the window pane, You can double-click a row to open the topic or other file |
he Analyzer interface. You can also select the row and click "File=5end to Flare” to open the file in that application.

Suggestion  —Conted File Title Folder il

This window displays places in your project where the XHTML markup (code) can be improved (e.g., empty tags, COATA tags, empty attribi
‘ i

Remowve line breaks <p>The following icons ... | conversion_rules.htm Extension Conversion Rules Content/
Make single space =p=The following icons ... | conversion_rules.htm Extension Conversion Rules Content/
Remove tags with spaces <p=&FLE0; < /p= conversion_rules.htm Extension Conversion Rules Content/ =
Femove line breaks =p==img src="Downextc.. | conversion_rules.htm Extension Conversion Rules Content/
Make single space <p><img src="Downexte... | conversion_rules.htm Extension Conversion Rules Content/
Change non-breaking space.. | <p><img src="Downextec.., | conversion_rules.htm Extension Conversion Rules Content/
Remove line breaks <p><img src="Upextcon... | conversion_rules.htm Extension Conversion Rules Content/




Analyzer

¢ Demo...



So Which One Should | Use?

¢ Depends whether you need:

— A quick look at core issues — Project Analysis pane.
— A dynamic look at the project’s files — File List.

— An informational report to be printed for use at or
away from the project — Report feature.

— An Informational report that can be customized for
your needs — Report feature with file tags.

— Dynamic reports that can help you make the changes —
Analyzer reports.



Hyper/\Word Services Offers...

Training ¢ Consulting « Development
»Flare « Advanced Flare (thru MadCap)
»VIZIAPPS
»Single sourcing ¢ Structured authoring

WI2INPPS
Certified Expert



"ll-.-.

mmadsk.illz

THANK YOU FOR ATTENDING TODAY’S

_ WEBINAR!
As a webinar attendee, receive our next

advanced training course. Just $499 per student!

May 27-28, 2015 (web-based)

June 25-26, 2015 (web-based)

*Offer valid through April 30, 2015.

Note: Courses subject to change. Availability based on student registration. Contact us for the latest schedule and course availability.

TO RECEIVE YOUR DISCOUNT, CONTACT:
sdles@madcapsoftware.com | +1 858.320.0387 opt.]




Thank you... Questions?

YPERWORD

SERVICES

978-657-5464
nperlin@nperlin.cnc.net
www.hyperword.com

Twitter: NellEric

WI2INPPS

Certified Expert



http://www.hyperword.com/
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