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Who am I?

o Technical Writer for 18+ years;
incorporated consultant 11+ years

» B.S. Cognitive Science;
Master of Technical & Professional Writing madskils

o Certified Flare Instructor & Developer

e FrameMaker user since version 4; print-focused and
heavily involved in template design

e Flare user since version 1.0; started from scratch

e Learned HTML/CSS to manipulate Flare output
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Who are you?

 You have a bunch-o-doc to get into Flare

e Ideally, you:
» Are not under the gun
» Are not working on production doc
» Are familiar with FrameMaker styles

» Are able/willing to spend {considerable} time
planning and experimenting before diving in

» Know a bit of HTML/CSS (or are not shy about

learning — see Pam Coca’s recent webinar)

» Do not seek the magic bullet
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This is a case study; sorta...

e I'm coming at this from a large-project perspective,
but many concepts apply to any conversion project

» Composite case study from multiple clients

'an )

» The largest project involved converting 57 Frame
docs (-3,000+ pages) in 10 weeks (400 hours, on bid)

» Will discuss some basic process strategies

e Will show some issues you may encounter and some
ways of dealing with them

» Pre-import cleanup on the FrameMaker side

) Post-import cleanup on the XHTML side
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Where we're going

@ Evaluate and analyze Document the process
@ Start small @ Import to Flare

@ Tame your styles @ XHTML cleanup
@ FrameMaker cleanup Think big
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Is it worth converting at all?

» Analyze the payoft: time spent vs. gain

» For a small number of short docs, it may be easier
to just cut & paste or export to text and format later

» For a few longer documents/books, could use Flare
import mainly as a mechanism to split content into
topics, and massage the content later

» For truly large projects, the time you spend working
out a detailed conversion process can pay oft

-‘l-_-

3 4 1

pooezipn,




Converting? Migrating? Both?

o Is the goal simply to switch tools and reproduce your
FrameMaker output via Flare, or is there also major
rewriting/restructuring needed?

» Example: stable product, wanted richer help & CSH
without chop-my-book-up-into-chunks mechanics

» Example: two products merged under a new UI —
focused on templates, not conversion

e Depending upon your goals, likely not a straight line
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See what you're dealing with

» Review a variety of documents — don’t just take one
as a sample (especially if it’s not your content)

e Goal: Analyze & evaluate so you can make decisions
on what to implement and what to let go of

» What styles are {activelyl used? Are there Overrides?

e How consistent is the document structure?




See what you're dealing with

o Are there any layout-dependent design elements?

» Sideheads? Sidebars? (They ‘can’ be done in Flare,
but only with an absolutely consistent structure)

e How are Notes/Tips implemented?

% NOTE

4 AS par agr aphS? At the end, include a Closing paragraph.

This mnserts all the

2 AS tableS? mmformation, and 1

always be the last

e Is there conditional text?

>

These buttons turn blue whenh you hover the
mouse over them.

o A builet
= Another bulet

» Large sections or small chunks? How much?

» How many conditions? Are they still relevant?




@ See what you’re dealing with

‘XZ Id el facilis=e vulla nisim arnare lobar, aliquet consequipis lobortio quis ipisl
H hat types Of tableS? daolortis. UWlaor scilis aciliqu vercilisit ese eriure dolessed

Id el facilisse vulla nisim arnare lobor, aliquet consequipis lobortio quis ipisl

} HOW many fOI‘matS> dolortis. Ullaor scilis aciliqu vercilisit ese eriure dolessed

» How complex? For data? For design?
» Do they have proper heading rows?
* How are numbers/bullets implemented?
» How many types? Are headings numbered?
e How are cross-references used?
» Only to headings, or to figure/table captions?

» References to specific list/step numbers?
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@ See what you're dealing with

e How are graphics used? Click ) to s a bigger versionds
» Are they embedded or referenced?
» Which gr aphiC formats?
» Are there multiple objects inside anchored frames?
» Where are frames anchored?
» Any inline graphics?

» Anything else of note?
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Start small

o Select 2-3 representative documents
e Build a composite ‘sampler’ document if needed

 The goal is to capture a complete cross-section of
the formats, structures, conventions, and quirks in
the files you’ll be working with so you can test how
you might either implement them or purge them




1 CATALOG
article

@ Think ‘clean and simple’ =

Body2+
Body3
Body3+
body4
Bodylndent

e Legacy FrameMaker documents accumulate cruft |siren

Bulleted

CelBody

» Extra styles! Caboyouci

CelBullet?
CelHeading

- (paralndent, paralndentMore, o

ChapterMumber

paralndentJustABitMore, e o

CodeBlock

paralndentJustALittle WeeBitMore...) ot

Footnote
heading
d Headingl
» Lots of overrides! e
. Heading1NoNumber
Headingl Top
Headingl Underline

Heading2
» Extra master pages! eadragoes

Heading3
Heading3NoBreak

HeadingNoMNumber
» Extra reference pages! esinofin

nte

IndentedMaore
MNumbered
Humbered]
Numberedalpha
NumberedalphaFirst
NumberedFirst
NumberedFirstindent
pagebreak
shippet
it Steps &

Delete...
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@ Target the Cruft

» Wikipedia: “Cruft is jargon for anything that is
left over, redundant and getting in the way. It is
used particularly for superseded and
unemployed technical and electronic hardware
and useless, superfluous or dysfunctional
elements in computer software.”

“Whoa... hold on, Jobn — Flare will ignore unused
styles, and I can just delete the other junk after
importing”
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1 CATALOG

article
Body

body
Body2
Body2 5
Body2+
Body3
Body3+
body4
Bodylndent
Bodylndent33p=
Bodyindentéw/eeBitM
BodyindentMore
Bulleted

CelBody

CellBadyleft
CelBodySpecial
CellBullet

CelBullet2

CelHeading
CelRight
Chapterdlpha
ChapterNumber
ChapterTitle
ChapterTitleBigager
CodeBlock
CodeBlock\wide
CodeSmall
Footnote

heading

Headingl

Headingl noBreak
Heading1NoNumber
Headingl Top
Headingl Underline
Heading2
Heading2Break
Heading3
Heading3MNoBreak
HeadingNoMNumber
HeadingRunln
Indented
IndentedMaore
MNumbered
Humbered]
Numberedalpha
NumberedalphaFirst
NumberedFirst
NumberedFirstindent
pagebreak

shippet

Steps

Delete...



@ So is cleanup worthwhile?

e As I frequently work in code view; I am admittedly
distracted by messy code (‘code gremlins’)

o It doesn’t hurt to do a quick & dirty
import of your book into Flare and
see what happens

o If you're happy with the vissble results
then fine; if not then you have more
work to do

* So many ways you could tinker...
need to figure where to draw the line
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@ Decide what you want need

e Make a complete list of FrameMaker styles in use

o Take this as an opportunity to start fresh and trim
down your style catalog

e Build a spreadsheet:
» Make a complete list of FrameMaker styles in use

» Make a list of Flare styles you need — start with the
basics and expand from there as needed

e Don’t hang on to old names for the sake of nostalgia

» Preserve style names if in doubt; easy fix later
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Frame Style

Flare Style

standard HTML;
Body, TableBody p don’t necessarily need
special TableX formatting
Heading2Break, b standard HTML;
Heading2NoBreak, ... handle breaks with CSS
Code p.code, span.code sttt R
character styles
stepFirst/Next,
stepIndentFirst/Next, Simplity!
alphaFirst/Next, p.numbered, p.alpha | Document structure may
alphalndentFirst/Next, not need First/Next styles
tableStepFirst/Next,

7




bisse’
Back up! ...somewbhere

o Always work on a copy; keep an original somewhere

*Dropbox is more
sync than backup

 Duplicate your project folders before each major
change so you can step back a notch or two if needed

MyPro;ect original hk \yPrO]ect copy h MjProject-copyz
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Purging FrameMaker cruft

e FrameMaker’s built-in functions are a start

» Easy to blow away style overrides by m rrrrr t =
importing a document’s own formats| e /e
and clearing overrides B =

» More tedious to manually delete |:
Styles from all ()f your documents WTEMU;?]:"?;E:::; 7| Dther Format/Lapout Overiides
and re-import from a clean template |si ]

» May still have a lot of re-tagging to do

e But...imagine doing that on dozens of files — there
are far more eflicient ways of working

GWM/&@@/ e,
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Cue the third-party tools

o Silicon Prairie Software (siliconprairiesoftware.com)

» Tools to list paragraph/character/table formats in
use, delete unused formats, rename formats, remove
overrides, and more

» Also tools for variables, cross-references, etc.

» Inexpensive, $10/seat

o {Demol
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And, for seriously heavy lifting...

e FrameScript (framescript.com)

» Very powerful — ideal for tasks that are much more
complicated, yet still repetitive

» Sx50/seat (V6 on sale in July), so may not be an option
for those migrating unless there’s really a lot to do

» Rick Quatro (rick@frameexpert.com) is master of all
things FrameScript; he has a broad resource library

o If you have FrameScript, the [il-frame tools are very
useful, but in the $hundreds (-frame.itl.info/en.html)

e [Demol
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@ Before you import...

e Go back and update your style map/comments

e Document your process

» Easy to forget the sequence of steps or the logic
behind them (fwiw; my memory is also lousy...)

» Essential if multiple people will be pitching in at the
mass-conversion stage

» Make note of any other quirks you've found

e Make another backup
« Re-Caffeinate pWB
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@ Document your process

¥ 2 Pare down existing styles
¥ 2.1 Paragraphs
e 2.1.1 Selectbook

e 2.1.2 Run Tools > Paragraph Tools > List Paragraph Usage get an idea of what's in there

® 2.1.3 Run ! _Control_Script3 FrameScript Strips content out of Code/Example tables, and deletes all
reference pages (that's key here at the moment)

e 2.1.4 Run Tools > Paragraph Tools > List Paragraph Usage List should be significantly shorter

e 2.1.5 Run Tools > Paragraph Tools > Delete Unused Paragraph Tags

e 2.1.6 Run Tools > Paragraph Tools > List Paragraph Usage should just be the top list now

¥ 2.2 Characters
e 2.2.1 Select Book

® 2.2.2 Run Tools > Character Tools > List Character Usage Iflistis short and neat (Bold, Code, Normal, Relief), don't
need to run character scripts
e 2.2.3 Run Tools > Character Tools > Delete Unused Paragraph Tags

e 2.2.4 Run Tools > Character Tools > List Character Usage Should be down to short list now
¥ 2.3 Paragraphs 2
v 2.3.1 Open /Projects/Project_Templates/FrameMaker/Conversion_Templates/Style_Imports.fm
e Select all files in book (not the book itself)
e Do File > Import > Formats (fio)
e Set Import from Document to Style_Imports.fm
e Select only Paragraph formats from the top section; select both boxes in the bottom section
e Click Import; click OK to dismiss the waming.
2.3.2 Open /Projects/Project_Templates/FrameMaker/Conversion_Templates/ParaTagConversions.fm
2.3.3 Run Tools > Paragraph Tools > Convert Paragraphs
2.3.4 Run Tools > Paragraph Tools > Delete Unused Paragraph Tags
2.3.5 Run Tools > Paragraph Tools > List Paragraph Usage should just be the top list now
¥ 2.4 Characters 2

® 2.4.1 look at character overrides; alternate between List Character Usage, Delete Unused Character
Tags, Report: Format Overrides, and Convert Character Formattings to Tags

¥ 3 Conditional text
¥ 3.1 Run i-tools > Quality Pack > Report: Condition Formats
e 3.1.1 ifnone used, run Quality Pack > Remove Conditions
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@ Import to Flare (finally...)

e Remind yourself that this is a massively iterative
process — import, examine, tweak, repeat

* There are oodles of import parameters to tweak

e You can create multiple import files (flimp), each
applied to different Frame files with different settings

o Avoid using subheadings ~ e -
within topics if you can, e —
but don’t map all of your ™™™ T
heading levels to hi yet o —-w
(that’s easy to fix later)* ™0 e ®
* Sorry, that’s a whole session of its own Character Styles Z::m "
Cross-Reference Styles _

5 Imported Files 4HeadingTOC
4 Activelx




@ After you import...

o Pause for a moment of joyful reflection —
you’'re now dealing on/y with plain text files

» Heck, you can edit them in Notepad if you want!

» But, consider a powerful text editor that can do
search & replace recursively across multiple
directories at once via regex/grep*

» I use TextWrangler (Mac) or TextEdit (Windows);
there are others such as BBEdit, Notepad++, etc.

» Get at least one license for MadCap Analyzer

* More on regex/grep in a minute, but do note that Flare 9 does support this

GW}%&@@/ e,
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@ XHTML/CSS cleanup

e Code gremlins — entirely harmless, but annoylng

» <b style="font-weight:normal;”>...</b>

p <i></i>

» <span>...</span>

» <{CDATA[ 1}>
e Okay, but not so great:

» <b style="font-style:italic;”>...</b>
e Definitely not a good thing:

(11 )

» <p style="...”>..</p>
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@ Batch search & replace

e Make a list of

gremlins

e Advanced Find
and Replace
(abacre.com)

e Boom. Gone.

<I[CDATA[ 1]=
<i=<f=
<bx=</b>

<= <fix

<h> </b>

<ux</u>

<u> <fu>
<i=<I[CDATA[ ]]==</i=
<b=<I[CDATA[ J]=</b=>

<span
<span
<span
<span
<span
<span
<span
<span
<span
<span
<span
<span
<span
<span
<span

<span

class="F__Times_New_Roman__Fs__12_00p" style="font-style: normal;"></span>
class="code">=</span=

class="F__Times_MNew_Roman__MNot_Bold"></span=
class="F__Times_New_Roman__Fs__ 12 _00p__ C_ "=</span=>
class="F__Times_New_Roman__Fs__ 12 00p__ C___ L Amer__English"=</span=>
class="F__Times_New_Roman__MNot_Bold__Fs__ 12 _00p"==/span=>
class="F_Times_New_Roman__Not_Bold___MNot_Italic"= < I[CDaTA[ ]]=</span>
class="F__Times_MNew_Roman__MNot_Bold___Mot_TItalic"=</span>

class="F__ Times_New_ Roman__Not_Bold__ Mot _Italic_ C_ "= <I[CDATA[ ]]==/span=

class="F__Times_Mew_Roman__Fs__ 12 _00p__ C Brit__English"></span=>

L
class="F__Times_New_Roman"> </span=
class="F__Times_MNew_Roman"=</span=>
class="F__Times_New_Roman__Fs__ 12 _00p"=</span=
class="F__Times_Mew_Roman__Fs__12 00p__C___ | Brit_ English"==/span=>
class="F__ Times_Mew Roman_ Mot Bold Fs 12 00p_ C L Brnt_ English"=</span=
class="F__Times_New_Roman__Fs_ 12 _00p"= <I[CDATA[ ]]=</span=
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@ Regular expressions and grep

e Search and replace on steroids
» Backreferences; like search & replace with variables

» Not the most intuitive, but spending a few hours
learning regex/grep can save many times that in
repetitive drudgery

e Tools such as RegexBuddy/RegexMagic help

develop complex search & replace expressmns
(just-great-software.com)

Find . & - N 7
! img src=". M \.pngl\.gif)(" />
}
. emo | Replace o
| \1Resources/Images/\2\3\ \4
Matchin [
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Consider the big picture

» Make your life easier by organizing your topic and
graphics files

Example: after importing, you have many dozens of
graphics in a flat directory with your topic files:

» From the Content Explorer, select all images and
drag into /Content/Resources/Images

» Or, move them via Windows Explorer . '
| | P
and relink them via search/replace
[Demo}

2



Consider the big picture

o File naming conventions are helpful
» can be worked out in a later phase if necessary

» Filename markers can be embedded in Frame
documents before import, but it’s a time sink

» If you use icons inline for . buttons, etc., an img.icn
class could drop them a tad below baseline and add
a little extra padding...

e Consider your project architecture
» How many projects might you need?

» How might you use a Master Project?

30
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%9 So what now? W

» Update your process documentation

e Grab a few more documents and run them through
your process to see if you get the same outcome

o Lather, rinse, repeat until you're comfortable with
the results

e Grab a friend or unwitting co-worker
and run the remaining documents
through the conversion process

31



To sum up...

@ Evaluate and analyze Document the process
@ Start small @ Import to Flare

@ Tame your styles @ XHTML cleanup
@ FrameMaker cleanup Think big
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$100 OFF mmodskills TRAINING

Thanks for attending today’s webinar!

As a webinar attendee, receive $100 off any MadCap Training Course:

Discount Code MSTRN100*

For available training courses and to receive your discount, contact:
sales@MadCapSoftware.com
+1 858.320.0387 opt. 1

*Valid for any current or future training course reserved by August 15, 2013

-
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(Questions?

“anyone......anyone
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Thank you

jwelle@gwinfodesign.com
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