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&- madcap LIVE WEBINAR @

BEFORE WE GET STARTED...

<]

The webinar will be recorded Use the Question Panel in
and emailed to all registrants GoToWebinar to ask questions
throughout the webinar




Who Am |?

Nelil Perlin - Hyper/Word Services.
— Internationally recognized content consultant.

— Help clients create effective, efficient, flexible content
In anything from hard-copy to mobile.

— Certified — Flare, Mimic, Viziapps, others.

— Working in online since 1986, mobile since 1998,
XML and CSS since 1999, apps since 2011.

— Certified app development consultant and trainer.
— Lynda.com® author of training for Flare 12, others.



¢ Flare’s link types

¢ Insertion and customization
¢ Pros and cons

¢ Some general design notes



Hyperlinks
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Hyperlinks

ere's a standard hyperlink to topic B. .
Here's a cross-reterence (xref) to Topic B.
Here's a topic popup to Topic B.

Here's a text popup.

Topic B

Welcome to topic B.



Insertion and Customization

¢ Insert — Use Insert > Hyperlink, or press Ctrl/K,
or click Insert Hyperlink icon on toolbar.

¢ Customize — Use “a” in the CSS.

ré Styles.css
o | Styles.css x Start Page =
Stylesheet Editor | @s View: Advance d % Add Sele
All Styles * Hide Inherited 12

(Linked Styleshests)
(Generic Classes)

I [Generic Pseudo Classes)
(ldentifiers)

I [Complex Selectors)

(Custom Lists)
— I a



Pros and Cons

¢ Pros:
— Can link from anything to anything.
— Familiar.

¢ Cons:
— Takes readers out of their reading path.
— A maintenance problem if the target’s title changes.
— Author must type and edit the link text.

— Link style format is fine for online targets but what
happens in print targets?

— One possible answer...



Cross-References
(xrefs)
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Cross-References (xrefs)

\ 4

Here's a cross-reference (xref) to Topic EE

Here's a topIC POPOR 10 TODIC B

Topic B

Welcome to topic B.



Cross-References (xrefs)

¢ Changing the target topic title from “Topic B” to
“Topic X does this to the xref text.

Here's a cross-reference (xref) to Topic X
Here's a topic popup to Topic X
Here's a text popm

Here's an expanding text link .
&l Here's a dropdown link.

And, finally, here's a [ toggler.



Cross-References (xrefs)

¢ The update Is automatic across the entire project
when you build.

¢ Don’t want to wait until you build? Select Tools
> Update Cross-References.



Insertion and Customization

¢ Insert — Use Insert > Cross-Reference, or press
Ctrl/Shift/R, or click Insert Cross-Reference
Icon on toolbar.

¢ Customize — Use “MadCap | xref” in the CSS.

= Styles.css

| Stylescss = Start Page =
Stylesheet Editor | a8 View: Advance d %5 AddSel
All Styles * Hide Inherited L

:
!
dadCap | tocProom,
dadCap '.:::::5'.
adCap | topi
!
!




Pros and Cons

¢ Pros:

— Automatically changes the link text as the target title
changes.

— Automatically changes from a link format in online
targets to a page reference format in print targets.

— Works for jumps and popups.
¢ Cons:

— Can only be used between topics in the same target —
can’t be used for jumps to external URLs or files.



Automatic Format Change

¢ Based on the medium.

— Styles.css > 0 %
fa| Stylescss = Start Page = 3 =
Stylesheet Editor | &s| View: Advanced | % Add Selector Manage Font Sets  Options -
All Styles ~ Hide Inherited =) Medium: (default) ~  Show: Assorted Relevant Properties =
PRI L |3 e L . ) . . -
MadCap | snippetText Medium: (default) X Medium: print x
MadCap | tocProxy MadCap|xref MadCap|xuref
b MadCap | :HM|;,J I Fant Font
s o 4 |nclassified 4 Unclassified
MadCap | topicToolbarProxy
dadCap | variable - {paratext} Iz' mc-for
E R adCap

[paratext]” [pageref]




Setting the Format

I L 1 P

-

Licels Lot

Cross-Reference Format

Enter format (preview below):

7

(=] | Meadium: {default)

*  Show: Assorted Relevant Properties =

Available commands:

Showe All

Command

Description

Start bold text

{/b} End bold text

{bg red} Start new background color
{/bg} End background color
{color red} Start new text color
{{color} End text color

{default} Reset all font changes

(Double-dick command to insert)

Cancel

I

N Font
4 |Unclassified

mic-Tormat;

Medium: (default)
MadCap|xref

[paratest} |Z|



Popups — Topic
and Text
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Topic Popups

Topic A

Here's a standard hyperlink to topic B.

__- e S e Saaaea o Topic B
Here's a topic popup to Topic B. _—
Here's a text popup. -

Here's an expanding text fink L.

I Here's a dropdown link.

And, finally, here's a [ toggler.

¢ Supported in HTMLS5 tripane but not yet In
TopNav or SideNav — feature requested.



Insertion and Customization

¢ Insert — Use Insert > Hyperlink or Cross-
Reference and select Popup Window for the
Target Frame field.

¢ Customize — Use “Popup” D) oo * (Ehitie

Stylesheet Editor | as View: Advance d | % Add Sel

sub-class of “a” in the CSS. m—

(Linked Styleshests)

(Generic Classes)

I [Generic Pseudo Classes)
(ldentifiers)

I [Complex Selectors)
(Custom Lists)




Pros and Cons

¢ Pros:

— Good for short pieces of content like a phone number
or showing interim steps In a larger procedure without
taking the reader out of the task path.

— Can automatically display a glossary term’s definition

I

— Po
lin

popup form when that term appears in a topic.
pup links In multiple topics can use one topic as the

K target so maintenance Is easy — make any changes

In one place.



Pros and Cons

¢ Cons:
— Windows controls where a popup opens.
— A popup opens on top of the starting topic so it may
cover content.

— New users may be unsure how to close a popup In
order to keep reading in the primary topic.

_30

y
N0

pups In targets running on mobile devices become
perlinks, a problem if your design is based on using

UPS as popups.



Text Popups

Topic A

Here's a standard hyperlink to topic B.

Here's a cross-reference (xref) to Topic B.

Here's an expanding text link .

Topic A

Here's a standard hyperlink to topic B.

Here's a cross-reference (xref) to Topic B.
Here's a topic popup to Topic B.
Here's a text popup.

The tech support phone ¢ [
Lnuml:}er s 111-599-1212.

R et EA R B

And, finally, here's a [ toggler.



Insertion and Customization

¢ Insert — Use Insert > Text Popup.

¢ Customize — Use “MadCap | popupHead” in the
CSS for the link, “MadCap | popupBody” for the
popup Itself.

I MadCap | popup
MadCap | popupBody
MadCap | popupHead
dadCap | grlode



Pros and Cons

¢ Pros:
— Short and simple code.

¢ Cons:
— Opens on top of the link so It may cover content.

— Each text popup is a separate code instance; changing
It iIn multiple places is a maintenance headache.

— Popups In targets displayed on mobile devices convert
to hyperlinks, same design problem as before.



Dropdowns
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Dropdowns

Here's a topic popup to Topic B.
Here's a text popup.

fext link [

Here's an expanding

And, finally, here's a I toggler.

Here's a topic popup to Topic B.
Here's a text popup.
Here's an expanding text link .

& Here's a dropdown link.
And here's the body for the dropdown link.

And, finally, here's a [ toggler.



Insertion and Customization

¢ Insert — Use Insert > Drop-Down Text.

— Insert >Dropdown Hotspot creates the hotspot and
adds “(Thais 1s the dropdown text)” as a placeholder
for you to modify.

¢ Customize — Use “MadCap | dropDownHotspot”
In the CSS.

MadCap | dropDo
MadCap | dropDownBody
MadCap | drepDownHead

I MadCap | dropDownHotspot
dadCan | endnnteRlnck



Pros and Cons

¢ Pros:

— Like a popup but the body displays in a “stretched-
down” area of the screen so dropdowns don’t cover
other content like popups do.

¢ Cons:

— None I can think of but I’m open to other opinions.



Expanding Links
(aka Slideouts)
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Expanding Links

Here's a topic popup to Topic B.

& Here's a dropdown link.
And here's the body for the dropdown link.

And, finally, here's a @ toggler.

Here's a topic popup to Topic B.
Here's a text popup.
Here's an expanding text link & (where the text slides out to the right).

= Here's a dropdown link.
And here's the body for the dropdown link.

And, finally, here's a [ toggler.



Insertion and Customization

¢ Insert — Use Insert > Expanding Text.

— Insert >Expanding Hotspot creates the hotspot and
Inserts a blank block in which to add the body.

» Select Show Tags > Show Markers to see it.

¢ Customize — use “MadCap | expandingHead”
and “MadCap | expandingBody” in the CSS.

| |
adCap | ex B
adCa | ngHe d
Al



Pros and Cons

¢ Pros:
— Simple code.
— (Good for short, text-only content like short glossary
definitions.
¢ Cons:
— Text-only.

— Something about reformatting a paragraph on-the-fly
seems to bother people.



Togglers
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Togglers

Topic A

Here's a standard hyperlink to topic B.

Topic A

Here's a cross-reference (xref) to Topi
Here's a standard hyperlink to topic B.

Here's a topic popup to Topic B.
. And here's an additional paragraph and an image that | added to demonstrate the toggler.
Here's a text popup. :

Here's an expanding text link & (whe m

Here's a cross-reference (xref) to Topic B.

& Here's a dropdown link.

And here's the body for the dropdo Here's a topic popup to Topic B.

< And; finally, here's a [ toggler.

Here's a text popup.
Here's an expanding text link = (where the text slides out to the right).

& Here's a dropdown link.
And here's the body for the dropdown link.

And, finally, here's a =& toggler.
Steps

1. Do this.

2. Do that.

3. Do the other thing.



Insertion and Customization

¢ Insert — Use Insert > Toggler.
¢ Customize — Use “MadCap | toggler” in the



Pros and Cons

¢ Pros:

— Like a dropdown but can show or hide any content
anywhere and at the reader’s discretion.

¢ Cons:

— Requires multiple steps — creating the content, naming
the content to be togglerized, creating the toggler, and
assigning the content to the toggler.



Some General Design Notes

¢ Hyperlinks and xrefs are good to link to related
content but bad if the link Is In the middle of a
procedure — easy for readers to lose their place.

— Use popups, dropdowns, or togglers instead.

¢ Need to run targets on mobile devices? Popups
convert to hyperlinks.

¢ Importing old Word or FrameMaker documents
Into Flare? Get rid of underlining used for text
emphasis.

— Readers will think they’re links.



Some General Design Notes

¢ Single-sourcing to online and print targets? Use
xrefs, not hyperlinks, to get the page reference
format in the print.

¢ Think twice before customizing your link styles
away from what people are familiar with.
— From OWL Guide to WinHelp to HTML Help.

¢ Where to place links in a topic — top, bottom, or
In-context?



¢ In other words, lots of link options beyond
standard hyperlinks and popups.



Hyper/Word Services Offers...

Training * Consulting * Development
» Flare and MadCap Suite
> Assessing readiness for “mobile”
» Guidance toward Information 4.0
» VIZIApPPS
> Single sourcing  Structured authoring

Certified Expert

283 Information4.0
"‘. OOOOOOOOOO
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MADWSERLD

APRIL 14-17, 2019 | HARD ROCK HOTEL

Register by March 15 to Save Up to $400
WWW.MADCAPSOFTWARE.COM/CONFERENCE/MADWORLD-2019


https://www.madcapsoftware.com/conference/madworld-2019/
https://www.madcapsoftware.com/conference/madworld-2019/

MADWSRLD

}U]BLIN IRELAND

OCTOBER 8-11, 2019 | THE MARKER HOTEL

Register by March 31 to Save Up to $900
WWW.MADCAPSOFTWARE.COM/CONFERENCE/MADWORLD-2019-DUBLIN


https://www.madcapsoftware.com/conference/madworld-2019-dublin/
https://www.madcapsoftware.com/conference/madworld-2019-dublin/

Thank you... Questions?

YPERWORD

SERVICES

978-657-5464
nperlin@nperlin.cnc.net
www.hyperword.com
Twitter: NeilEric

madcap madca
MIMIC Wi2IAPPS  gsinformationd

CERTIFIED INSTRUCTOR CERTIFIED INSTRUCTOR Certified Expert


http://www.hyperword.com/

